Life Gets in the Way

It’s been nearly a month without a post. While some things have happened in the meantime, not a lot of new developments have occurred.

Microbee: First the bad news

Yeah. That’s not right.

I was supposed to be bringing one of my Microbees to the Perth Amiga Users Group gathering, so of course, I chose the DRAM 128k with the external Gotek…

Of course it decided to fail two days out and I am yet to recover it at this point. There’s been a lot of back and forth on the Microbee forums as to what may be causing the problem but I don’t yet know what the root cause is. I’ll keep looking.

Current symptoms are that when you turn it on, you get no synch on the monitor. If you repeatedly press the Reset button, you sometimes get the “I’m booting” cursor (But no boot) or garbage on screen. If you repeatedly press the Reset button, while holding down M, you sometimes get the Monitor but no characters. I’ve managed to get a RAM test working and the RAM is checking out.

Microbee: Now the Good News

Classy! Pity the desk is such a mess.
Even the back looks good.

The case is finished and it looks amazing! I need to do a final version in clear and smoked acrylic but I am super happy with the way it eventually came out. There is a minor issue, but so minor I’ll correct it without having to cut another test revision.

MSX: The Slow boat

Still waiting for the chip to arrive from China. Hope this one is not a fake…

Amiga 2000: Still Broken

I’ve been doing a lot of probing around and checking on this and I think it’s a problem with the Angus custom chip. I have also borrowed a DiagROM off a friend, but I need to get a null modem cable organised. There’s also another thing that will most likely help with this…

Pickups

…or more accurately drop offs as the person who gave these to me was kind enough to deliver.

So while I was at a local convention, I was approached by someone I have known for many many moons (And would consider a friend) approach me and ask if I wanted some Amigas. Of course I said “Oh yes please!”. She and her partner were downsizing and the systems had been sitting in the cupboard for a while.

Now it took a few weeks for timings to be right and the whole time between the initial offer and the systems arriving, I didn’t want to say anything in case I jinxed things đŸ™‚

(This was particularly difficult at the Perth Amiga Users Group, I can assure you)

But in time, things aligned and my friend dropped off not one, but two Amigas!

Left: Amiga 500, Right: Amiga 1000, Middle: cables, mouses, external floppy drive

These are, respectively, an Amiga 500 and an Amiga 1000. Oddly the 500 is the later (cost reduced) system. I had neither of these systems at this point. There’s also another 1081 monitor, 3 genuine Amiga “tank” mouses and an external floppy drive.

Knowing more than is possibly healthy about these systems by now, I checked, and unfortunately the battery in the RAM expansion on the A500 has rotted out. Thankfully the damage seems confined to the RAM expansion, and, even then, isn’t too extensive. I hope to have the RAM expansion fixed next weekend. I just need some parts.

See that dark green? Corrosion.

The A500 is also running an older version of Kickstart (Think of something like a BIOS, but more feature rich), which I found interesting. It suggests this system must be an early model. Unfortunately, as far as I can tell, the floppy disk drive on it is not working. Might just replace it with a Gotek and be done with it.

About that desk…

There’s also the original factory seal on the bottom of this system, which suggests it’s never been opened, which is amazing in itself.

You don’t see many of these intact

The A1000 has been opened at least once, by me, as some power supplies in these models have RIFA caps, which can explode. Thankfully mine does not have that problem and it’s absolutely fine inside.

Yes it will need some TLC.

The A1000 has an interesting configuration where the Kickstart of the system is on floppy disk, rather than in ROM like later models like the A500. Unfortunately I have not been able to get this one to boot off the provided Kickstart disks. I’m still working on that. One approach I have taken is to use the external Floppy with my Amiga 600, so I can copy files from the internal Gotek to the external Floppy.

The other thing about the A1000 is the custom chips were somewhat unique to this model… and one other model. That’s right! My Amiga 2000! (Later Amiga 2000s had a different chipset. The same one in the Amiga 500)

This means I’ll be able to use the A2000 to test the A1000 and vice versa. Happy days!

This A1000 is also complete. It has the keyboard, the keyboard cable, the front RAM cover and even the strange right angled connector on the Tank mouse. It’s super nice to have such a complete system.

Finally the 1081 monitor works fine, which is nice as these are very capable CRT monitors with SCART out on them.

Hey, the Amstrad was the first computer I could lay my hands on with a SCART cable handy.

Published by ilike8bits

I collect old computers and consoles

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: