Big Boi Mac

TLDR: I have a working Quadra 950

The Long Version: So on December 31, I went and picked up two Quadra 950s, in an unknown state, but one with battery damage.

Having taken the first off as a break (Being repeatedly woken by the neighbours, who decided to “party all night” does not help one’s ability to fix systems. I finally asked them to turn the music off at 5:15am, having already asked them to turn it down at 4am) I got stuck into the corroded system on the Saturday.

Pulling open the system revealed a long, still slightly sticky trail of rust and corrosion, running between two sets of SIMM sockets.

Eww!

It took me a few goes to get the system apart. The procedure (Which I have now done several times now) is as follows:

  1. Remove the front cover over the speaker. It’s held on with two clips on the bottom of the panel, and two near the top, which clip through the case and are accessed from the inside of the case. Unclip the speaker wire.
  2. Remove the drives and drive caddies. Don’t forget to remove power cables and both the floppy drive cable and the SCSI cable. The caddies are held in by a single screw on the front of each caddy. The are clipped in and slide straight out towards you. Be careful around the floppy drive. You may have to unclip one side of it’s front panel.
  3. Remove the caddy holder. It’s held in with two screws. It slides sideways towards the back of the case and then it slides forward.
  4. Remove the power supply. First, unclip the main board power connector. It’s held in with a small press clip. Then remove three screws. One at the front and two at the back. It slides out towards you.
  5. Remove the programmer and reset buttons. Gently squeeze them from inside the case just before they enter the front panel, then push them forward out of the front of the case.
  6. On the back of the case, on the right hand side, in line with the gap between the SIMM sockets is a spring loaded plastic clip. Push down on it and slide the whole motherboard sideways towards the front of the case. The whole motherboard will now be loose. Pick it up from the front side of the case and lift it out. The back half will follow.
POP! Dribble dribble dribble.

Once I had it out, I took it across to the sink and rinsed and scrubbed it to get the worst of the nastiness off it. I followed with plenty of vinegar. (I left it for a few seconds until the bubbling stopped). Another rinse under the tap followed by distilled water followed by a spray of Isopropyl alcohol over all the major chips.

I made sure I scrubbed the back too as some of the corrosion seemed to have worked its way down the legs of the SIMM sockets and out the other side. This worries me as it may mean the board has corrosion on one of the middle layers.

After that, out into the sun to bake off all the water. It was a nice hot day so the water evaporated easily. I flipped the board to make sure no water was hiding under anything and gave it a second spray of Iso.

While it was drying I checked out the SIMMs that had been in the system.

There were 12 SIMMs. Two were a complete write off. Two, however, seemed worth salvaging as they were labelled “8MB” so back into the whole water -> vinegar -> water -> distilled water -> isopropyl. The rest were completely fine. I have them a quick cleanup anyway and all out in the sun.

Drying in the Aussie sun. Yes, that’s a BBQ they’re sitting on.

Now onto the case. Same process as before then out in the sun. It’s pretty badly stained, but it’s inside the case so, what can you do?

Snot inside the case

I let that all sit and dry and started working on a Mac to VGA adapter. There are some articles out there that list all sorts of details, but the best guide I found was this one. I built myself a nice high bandwidth connector. Not pretty but who cares?

Not pretty, but my kind of not pretty.

Not wanting to work more on the systems, but not wanting to lose momentum, I also start looking at the floppy drive, which needs a whole lotta love. I start work on it but at this point I chose to stop for the night.

The next day I was feeling more enthused. I asked around on the “Vintage Apple and Macintosh Enthusiasts of Australia” Facebook group if there was anything I’d need to check before firing up the “good” system.

I also went and watched an excellent video on cleaning and servicing the floppy drive, while I waited for replies to my query on Facebook. I immediately got to work and cleaned and lubricated the drive.

I went back to check on Facebook, and after several cries of “Naah just turn it on” (Including one from a certain expert) I decided to plug it in and turn it on.

Nothing.

Hmm. Maybe the power supply? I have a spare. Swapped it over.

Nothing.

At this point I measured some resistances and the whole board seemed to be short circuited, showing only 5Ω of resistance across the 5V rail. Odd. That didn’t sound right. Out came the multimeter and I spent the next half hour checking resistance across all the Tantalum capacitors.

It all looked fine.

I even started looking if there were tricks to turning on the PSU by “hotwiring” it in a similar fashion to what you can do with ATX power supplies. It was about this point I made an important discovery. What I assumed were power buttons on the front? They’re the programmer’s button and the reset button. You need to plug in a keyboard and turn it on from there. D’oh!

Plug in the keyboard (and mouse for good measure) and press the button!
Immediately the enormous fan spins up… and spins back down. This is actually good! It’s doing “something”. A kind soul on the forums mentions that this is probably a bad PSU. Oh well. I do have TWO of them. Plug in the second drive and… whoosh! It roars to life.

I have the video plugged in and I wait and wait and wait, and just when I’m about to give up hope, up comes a hashed grey screen and a cursor. We have life! There’s the familiar “Insert floppy” symbol.

Alright!

I happen to have a floppy disk on hand so let’s check the floppy drive. The disk drops in fine, attempts to read, fails (As expected) and then ejects… Or tries to eject.

The eject mechanism made a sad little whine, then a grinding noise followed by a whirring noise. Welp. Time to look at replacing that gear that always fails. Sure enough it has turned to orange powder. It’s amazing! The gear literally is softer than chalk.

I turn the drive gear so the notch is to the front. This will trip the sensor so the drive stops spinning. I also reached out to my friend who is a much better 3D Printer person than me, to see if she can print me a replacement gear or two on her high end resin printers.

OK so we are now at the point where we can start building up the server some more. I have several SCSI hard disks and some SCSI CD ROM drives. I start “simple” by testing the three drives that came with the Quadras. The first disk I try doesn’t even try and spin up. The second makes a disturbing “pew pew!” noise and the third spins up but does nothing.

Time for some lateral thinking. I know it’s not termination. Could it simply be that the drive is unpartitioned? OK so if we start from that, how do we get the system installed? What about booting from CD? I wanted to put one in there anyway…

Out comes the CD ROM. I quickly find a copy of System 7.5.3 and burn it to a blank CD/ I check the jumpers are all “sane”, plug it in and hold down the ‘C’ key to tell the system to boot from the drive. Amazingly, it boots first time.

Happy Mac!

Yahoo! We have a working Macintosh! Best of all, the SCSI hard disk that’s in there is recognised. I do a complete install, and it even boots correctly. I am amazed.

Happy Drive

Just in case I check the other two drives and with either of them in, the system won’t boot. I think the drives themselves are completely dead. A pity, but 350MB should keep me going for now. Down the track I might buy a different storage solution, or work on some of my random SCSI CDs I have lying around the place.

At this point I check and I have 40MB of RAM already in this system. Short of the maximum 256GB, but not to be sneezed at. Wonder if I can do better? Remember those 8MB sticks? I pull them out, clean them up with an eraser, then reflow the contacts with fresh solder as the current surface is so bad it’s brown down to the copper.

Taking the outermost bank of SIMMs out and rebooting, my memory drops down to 36MB. Good. I figured this one has 2 banks of 4 x 4MB sticks for a total of 32MB and 2 banks of 4 x 1MB for a total of 8MB.

By removing the final bank or 4 x 1MB and substituting 4 x 8Mb I can theoretically bring it all the way up to 68MB. Let’s see if my Plan works?

So much RAM!

It works! I’ve salvaged the 8MB SIMMs.

At this point I start doing cosmetic stuff. The first thing I notice is that somewhere along the line, the system has taken an awful knock and both the case and PSU are actually bent. The case I’m using is also stained with something nasty that doesn’t want to come off the outside of the case.

The PSU I eventually fixed (After an abortive attempt to swap the shell with that of the PSU with dead capacitors) with some good old percussive maintenance. I hit it with a hammer over a block of wood until it’s back in shape. Now it fits nicely.

As for the case, I ended up swapping everything over to the other case, as it’s in a much better state. A bit of elbow grease and it looks quite presentable. As a side effect I discovered the speaker in the “dirty” case is dead.

(For those trying to keep up, there were two Quadras, one was clean in good shape but with a corroded motherboard, 2 dead HDDs and a dead PSU. The other Quadra had a bent case, a damaged speaker but a good motherboard and a working but bent power supply.)

This thing is a monster!

There is still a lot of work to do. For reasons I am currently unsure of, the CD ROM seems to have stopped. Not sure if it’s the drive or the system. (I’ve tried a second SCSI CD ROM but I don’t know if that one is good or not either. I’ll have to try my external case and see if the drive works with the SE/30). I also need to make a cover for the front of the system to cover the 5¼” drive bay but still allow access to the CD ROM.

There also may be some upgrades in the future. More on those as they come to hand.

I also want to start work on the second system. If I can, I’d like to salvage at least some of that system. Hopefully I can fix the mainboard and the PSU. It would be great to salvage another system.

Published by ilike8bits

I collect old computers and consoles

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: