Fixing the Amiga 2000 (Part 1)

EDIT: See the new final paragraph for some updates.

When I got the Amiga 2000, the initial fault reported was “Dead Power Supply”, but as it had been in storage for a long time, I suspected a secondary fault of “Battery damage” may have joined the original fault. The Amiga 2000 has an onboard rechargeable battery that, after 20+ years will ooze a green alkaline solution across whatever it’s near and proceed to eat it.

Made in Germany

As such I opened the Amiga with some trepidation. As I went, I made an interesting discovery, based on a throwaway comment on the Perth Amiga Users Group. It turns out what I have is a much earlier Amiga 2000. One of the original “German” systems. These are notably different insomuch as rather than being a “big box” version of the Amiga 500 desktop system, they’re the “big box” version of the original Amiga, aka the Amiga 1000.

This leads to some limitations in design that impact what can be done with these systems.
Firstly, the 1MB of RAM is 512K on the mainboard and 512K on a riser in the slot that later models use as a CPU upgrade slot.
Secondly the chipset is very much stuck in OCS territory, and it uses the older DIP format, the same as the Amiga 1000.
Thirdly the Video slot is much truncated compared to later versions. It really only has the same signals as the rear 23 pin connector.
Fourthly the Zorro slots are unbuffered, which means what upgrades will work is severely limited.

Onto the cleaning. I removed all the cards in the card slots and the memory riser. This is where I found something interesting! The power connector had been connected incorrectly. This may be the source of the reports of power supply failure. EDIT See final paragraph.

Janus Board. Basically an 8088 computer on a daughterboard.
Memory Riser. I believe I can upgrade this to the full 1MB by populating the top row with more chips.
This shorts a whole bunch of voltages. Not good.

I removed the drive/ power supply sled and the extent of the battery damage was revealed. It did not look pretty in there. The CPU had green legs and there was a circle of about 5cm of corroded components.

(For those watching from home, this is where I discovered all the photos I’d carefully taken were all blurry! WTF camera?)

Did I mention this is a BIG mainboard?

Removing the battery was… interesting. The corrosion has a particularly bad reaction with solder to render it into something closer to a ceramic. A mixture of metal oxides and other crud.

Initially I whacked on some of my good flux, tried adding some fresh solder, and using the desoldering station with the widest nozzle. The first conductor came clean straight away. The second conductor needed a quick refresh with some additional solder to clear the rest of the way. The final, most corroded pin that was attached to the groundplane? It sat there and sniggered.
I added more solder, which pooled and blobbed on my soldering iron.
I added more flux, which rapidly turned into fancy smoke, making no change to the joint.
I scraped away the top layer of brown gunge with a small jewelers screwdriver, added a more aggressive flux, added more solder until it had a bead on it, and then hit it with the desoldering gun and… it finally cleared!

A little pressure from the other side and the battery popped clear.

This… is… VARTA!!!! (That joke never gets old)

Right let’s inspect…

Eww. C43 and C44 have ceased to be.
Solder mask flaking away
Close up
More ewww! That chip with all the green legs? That’s the Motorola 68000 CPU.

OK so I have some work in front of me clearly.

Initially I hit the affected areas with white vinegar. This has the effect of stopping the corrosion from continuing by neutralising any remaining alkaline. I gave everything a scrub with a toothbrush at the same time.

I then rinsed the whole board in tap water to wash away as much of the vinegar as I could.

Out came all the socketed chips for inspection, a quick spray with isopropyl and, if needed, a further cleaning. Most were fine but some needed attention with an ink eraser.
I’m still not convinced the 68000 will be OK. if the alkaline has crawled up the legs into the innards, it may be an ex-processor.

Next I gave the board another scrub down, this time with distilled water. I then liberally applied isopropyl and put it out in the sun to dry, turning to make sure both sides were getting sun. I redosed with more isopropyl and repeated.

Amazingly, the board didn’t look as bad as I had initially expected. I took to the traces around where the battery had been with a fibreglass pen (I hate these things. They drop glass fibers everywhere which are a skin irritant. My solution is to put a piece of paper under what I’m working on and throw the whole sheet in the bin at the end.) and cleaned up everything including surrounding vias.

Everything seems to still be intact. It’ll need a new solder mask in a lot of places, but all things considered, it’s not to bad at all. There are two capacitors that literally only exist as leads now, but I’m not sure if that was caused by the shorted rail or by the corrosion or a combination of both.

Solder mask needed.

For now, it’s going in storage until I have significant time to look at it. The corrosion should be mostly neutralised, or at least dramatically slowed. In the new year, I’ll drag this out again and begin the slow job of seeing what needs further work.

EDIT: Thanks to Stewart Greenhill for this Amiga. (I never post names without permission first)
He has mentioned that the offset rail on the PSU was post the PSU blowing up so was actually not the root cause. It’ll make this repair more interesting. I suspect my easiest solution will be to replace it with a modern PSU, plus a “Tick” circuit. (Amiga 2000 has a clock signal synched to mains frequency, the “tick”, that it uses for video timings.)

Published by ilike8bits

I collect old computers and consoles

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: